'Service Stabilitrak' refuses to be fixed. - Chevy Colorado & GMC Canyon
 3Likes
  • 2 Post By ssgjurista
  • 1 Post By Tilley
 
LinkBack Thread Tools Display Modes
post #1 of 13 (permalink) Old 05-10-2017, 02:13 PM Thread Starter
Junior Member
 
Join Date: Mar 2017
Location: PA
Posts: 18
'Service Stabilitrak' refuses to be fixed.

I bought this truck three months ago with 32000 miles. On the way home, the Stabilitrak light comes on. I figured since there was a crap ton of snow, it must've been that. I called the dealer who sold it to me and they confirmed that. I also scheduled an appointment to have it fixed at my local dealer. They replaced my electronic brake control module and kept it for a couple days. Later that week, it pops back on again. I take it in again, they have no idea what to do other than put so dielectric grease on some electrical ends, thinking it's a short. It comes on whenever I start the truck the truck, or whenever I'm just about the park it. I do not hammer this truck, it's the nicest vehicle I've ever had so I want to last.

Fastforward two months and 3000 miles, it's back on again, so it's back at the dealer.. Onstar told me it's throwing a u0077 code. Can't find much information on it other than Stabilitrak and anti lock brake related. The warranty is still active til 48000 miles, but I can't keep dropping my truck off. I'm a full time nursing student with a full time job, I need this vehicle. Any idea what to do or where to point the techs to if they can't figure it out this time? I'm about to call up GM and throw a fit and get them to give me a huge discount on an extended warranty cause I'm nervous these problems will keep coming up..

Sent from my XT1585 using Tapatalk

Last edited by JimChevy15; 05-10-2017 at 02:18 PM.
JimChevy15 is offline  
Sponsored Links
Advertisement
 
post #2 of 13 (permalink) Old 05-10-2017, 02:24 PM
Senior Member
 
Join Date: Jan 2014
Location: DFW, Texas
Posts: 7,508
U0077 appears to be some sort of communication error. See link below.

PIT5457A: Service ABS / TCS / Power Steering and/or Suspension Message DTC U0077 U0121 U0126 U0131 U0139 U0151 U0401 U0415 U0428 (Circuit 5986 High Resistance) ? 2014-2016 Cadillac Chevrolet GMC | gm.oemdtc.com

Not sure it helps much. There are a lot of hits on that trouble code for other GM vehicles that point to various electrical connectors.

2015 Canyon SLT, Copper Red, 2WD, CC, SB, V6, Tow, blk leather, factory spray liner, safety pkg, generic roll up bed cover.
CaryBosse is offline  
post #3 of 13 (permalink) Old 05-10-2017, 03:24 PM Thread Starter
Junior Member
 
Join Date: Mar 2017
Location: PA
Posts: 18
A little, yes. It looks like they tested the voltage on the EBCM, no problems. It says that there could be an open wire on the driver's side step panel, so I'll give that a look if they don't find it.

They also checked the ohm wires and checked the pin tensions which were fine as well.

Sent from my XT1585 using Tapatalk
JimChevy15 is offline  
 
post #4 of 13 (permalink) Old 05-10-2017, 04:47 PM
Junior Member
 
tober's Avatar
 
Join Date: Oct 2016
Location: greensburg pa.
Posts: 21
Garage
i had stabilatrac and traction control warnings and truck went into limp mode about a month ago turned out to be a bad gas pedal sensor...hasn't happened since it was fixed...manager told me a lot of chevy vehicles having the same problem...maybe they can check on that
tober is offline  
post #5 of 13 (permalink) Old 05-11-2017, 11:16 AM
Senior Member
 
ssgjurista's Avatar
 
Join Date: Oct 2006
Location: Calcium, NY
Posts: 8,405
Based on the OP's initial post, my first thought is the techs are not exercising due diligence to track down the root cause of the issue.
CaryBosse and JimChevy15 like this.

"Brownstone Bumblebee" 2016 Diesel Colorado Z71 CCSB 4X4, Brownstone Metallic
HPD and Provent 200 Catch Cans, Amsoil Fluids, MetalMan Front Differential, Engine Oil Pan, & Steering Motor Skid Plate, Undercover Swing Cases
Say No! to Wheelers's Offroad!

"I respect everyone's opinion, no matter how wrong it may be."
ssgjurista is offline  
post #6 of 13 (permalink) Old 05-11-2017, 10:41 PM Thread Starter
Junior Member
 
Join Date: Mar 2017
Location: PA
Posts: 18
Quick update, it seems ssgjurista is probably right. They gave me a loaner vehicle so they can hunt down the issue. I bet they figured since it's the third time it's in for the same issue, they could get in a little trouble if they can't hunt it down or do something substantial. It just seems like there are far too many problems it could be for that specific code.

Sent from my XT1585 using Tapatalk
JimChevy15 is offline  
post #7 of 13 (permalink) Old 05-12-2017, 09:32 PM
Member
 
billa32778's Avatar
 
Join Date: Sep 2014
Location: Tavares, FL
Posts: 90
I've got a 2016 V6 Canyon with 31,000 miles and today while sitting at a traffic light the truck acted like it was going to stall out. When I put it in neutral and goosed the gas it straightened out as best as it's been lately (have been experiencing major shutter with the transmission not shifting down when accelerating from 40mph and 1,000 rpm) By the time the episode was over, which only lasted a few seconds I noticed that my Stabilitrax, Traction Control and Check Engine lights were on. A short time later the Check Engine light went off... the others stayed on until I shut the engine off and restarted.

Now I'm thinking I need to stop at the dealer tomorrow and report the incident just to have it on record since my warranty is only going to last another few months.
Should I be worried that I'm headed for major headaches? I really love this truck and will most likely get the Trifacta tuner at the end of the year to see if it will improve the trucks few flaws in performance.

FYI - I've already had the dealer do the Aug 2016 update to the control modules that is intended to solve a low speed shutter, which did help some but not totally.

2016 Canyon Crew Cab, Long Box SLE Bronze Alloy Metallic. Locking Diff, Trailering package, Splash guards and spray in bed liner.
Ordered 6/23/2015
TPW 7/13/2015
Produced 7/20/2015
In Transit 7/25/2015
Expected Delivery 8/14/15
Arrived 8/7/2015 Out of Town... Ouch!
Delivered 8/10/2015
8/19/15 Added GatorTrax retractable bed cover.
8/22/15 Tinted front door windows
8/22/2015 Added Steelcraft 5" Oval Step Bars
billa32778 is offline  
post #8 of 13 (permalink) Old 05-15-2017, 08:58 AM Thread Starter
Junior Member
 
Join Date: Mar 2017
Location: PA
Posts: 18
Definitely take it to the dealer Billa, especially if it's still under warranty. Thats what started me on this horrible path.

Dealer called again today, said they were in contact with GM Electrical Assistance because they had no idea how to replicate the codes they were getting. They think it could be they replaced my bad electronic brake control module with another bad electronic brake control module. Definitely not getting it back for another few days.

Sent from my XT1585 using Tapatalk
JimChevy15 is offline  
post #9 of 13 (permalink) Old 05-15-2017, 09:54 AM
Senior Member
 
Tilley's Avatar
 
Join Date: Feb 2015
Location: South Carolina
Posts: 894
Garage
I ended up replacing both wheel speed sensors to fix my consistent Stabilitrak issues. Dealer wanted $100 just to "diagnose it"... but the wheel speed sensors only ended up being $40 for both. Zero issues since the fix!
JimChevy15 likes this.

-SPONSORS-
| BAJA DESIGNS |
| BDS-SUSPENSIONS | KILLERWAXX SOCAL |
| LIVERNOIS MOTORSPORTS | RHINO-RACK |


2015 Colorado Z71 4x4
BDS Suspensions 7" lift | 22x12 -44 Grid Off-Road GD-4
325/50/22 Cooper Discoverer STT Pro


Tilley is online now  
post #10 of 13 (permalink) Old 05-16-2017, 04:40 AM Thread Starter
Junior Member
 
Join Date: Mar 2017
Location: PA
Posts: 18
Quote:
Originally Posted by Tilley View Post
I ended up replacing both wheel speed sensors to fix my consistent Stabilitrak issues. Dealer wanted $100 just to "diagnose it"... but the wheel speed sensors only ended up being $40 for both. Zero issues since the fix!
When would you Stabilitrak light turn on? What were you doing at that time?

Sent from my XT1585 using Tapatalk
JimChevy15 is offline  
post #11 of 13 (permalink) Old 05-16-2017, 11:25 AM
Senior Member
 
Tilley's Avatar
 
Join Date: Feb 2015
Location: South Carolina
Posts: 894
Garage
Quote:
Originally Posted by JimChevy15 View Post
When would you Stabilitrak light turn on? What were you doing at that time?

Sent from my XT1585 using Tapatalk
When braking and turning... either independently or in conjunction.

-SPONSORS-
| BAJA DESIGNS |
| BDS-SUSPENSIONS | KILLERWAXX SOCAL |
| LIVERNOIS MOTORSPORTS | RHINO-RACK |


2015 Colorado Z71 4x4
BDS Suspensions 7" lift | 22x12 -44 Grid Off-Road GD-4
325/50/22 Cooper Discoverer STT Pro


Tilley is online now  
post #12 of 13 (permalink) Old 05-16-2017, 10:44 PM Thread Starter
Junior Member
 
Join Date: Mar 2017
Location: PA
Posts: 18
Hmm okay interesting. Mine is like that too, below 5 mph.

Quick update. They said they installed a faulty electronic brake control module and they are replacing. If that's what it is, I can close this stupid case and hopefully help someone else.

Sent from my XT1585 using Tapatalk
JimChevy15 is offline  
post #13 of 13 (permalink) Old 05-20-2017, 04:11 PM Thread Starter
Junior Member
 
Join Date: Mar 2017
Location: PA
Posts: 18
Light came back on again. 😣😣

What the heck should I do? Try a different dealership and call GM or stick it out with this one? What would you guys do?

Sent from my XT1585 using Tapatalk
JimChevy15 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevy Colorado & GMC Canyon forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome