HOW TO: TB (Throttle Body) Cleaning (WITH PICS!) - UPDATED - Page 18 - Chevy Colorado & GMC Canyon
Reply
 
LinkBack Thread Tools Display Modes
post #341 of 344 (permalink) Old 12-05-2015, 04:29 PM
Senior Member
 
Join Date: Dec 2010
Location: Homestead, Florida
Posts: 4,846
to C'Fans.

Can't do much without the DTC. Try disconnecting the negative battery cable for a half hour or so. That should erase the DTC. See if it comes back.
cart7881 is online now  
Sponsored Links
Advertisement
 
post #342 of 344 (permalink) Old 03-07-2016, 09:25 PM
Member
 
FishSpike's Avatar
 
Join Date: Mar 2014
Location: Nebraska
Posts: 48
Omgosh!! I'm so happy I found this thread. I've been tracking the rough idle for 2 years I swear. I have a lot of new parts through this process though, ha. 2004 Colorado with 139,000 miles.

Used seafoam as directed, let it sit about 10 mins, started up and some nice smoke rolled out, took a cruise till it stopped. Still rough idle, which I figured but glad I did the sea foam anyway. Put some in the gas tank because I guess that's good to do.

Took off the throttle body, man was it dirty. Cleaned it spotless, used a whole can of throttle body cleaner, most of it at the end just blasting it clean.

Got it all back together and about cried, rough idle was gone. Took a drive and the shutter I had on deceleration was also gone. Sat in the garage just watching the RPM needle not move at all. The real test will be after tomorrow when I change the oil and put some miles on.

Thanks for all the advice on this forum! Wish I had come across this thread a long time ago. Amazing!!!
FishSpike is offline  
post #343 of 344 (permalink) Old 10-14-2016, 12:37 PM
Junior Member
 
Join Date: Oct 2012
Location: Shrewsbury Pa.
Posts: 11
Thumbs up

Thanks for the great write up!! I've had a 2005 colley for about 10 years. Its alwase been running a little ruff? The dealer said it ALWASE has? To fix it might cost about $100 to $250 to run it through a tester and find out what it might be? It had not thrown a code? YET! We now live in PA. And of corse next month is our Emmissions Inspection. NOW it throws a code of PO506. I went to do the clean up, and on the T body side, the hose had a gap on the bottem of about 1/16" by 1 1/2"?? The T boby was a black Mess. I was afrade to try, but cleaned it up and stratened the hose out and it went great. It has not run this good sence I got it!! IT cleared the code with in the first 5 minnets running. It has not run this smooth in over 100,000 miles we put on it...
Thanks for the write up and picts it helped a lot..


Djcool
djcool is offline  
 
post #344 of 344 (permalink) Old 04-14-2017, 03:11 PM
Junior Member
 
coloradorex's Avatar
 
Join Date: Apr 2017
Location: Virginia
Posts: 10
Garage
I know this thread is old but I tried this on my 2012 crew cab 3.7 with 51000 miles, I have had an irritating grumble/vibration in it for about 5000 miles starting out from a complete stop/ idle to accelerating and it only lasts about 1-2 seconds...really annoying...long story short did the whole 9 yards per your instructions and the old grumble is gone , runs so smooth now and I cannot wait to check this gas mileage (been getting around 16 city and 20-21 highway) hope it gets a little better sure can't hurt.Much thanks for taking the time to post this for folks !!!!
coloradorex is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevy Colorado & GMC Canyon forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome