light blinking in 4x4 and 2x4... - Chevy Colorado & GMC Canyon

ColoradoFans.com is the premier Colorado Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools
Old 01-30-2008, 01:13 AM   #1 (permalink)
Senior Member
 
Join Date: Sep 2007
Location: Saskatoon, SK. Canada
Posts: 543
Send a message via MSN to Shorty2301
Default light blinking in 4x4 and 2x4...

hey guys, was a bit chilly today (-40*C before the wind chill) and i went to change it from 4wd to 2wd and the light just keeps blinking, then click it back to 4wd, and it keeps blinking there too(blinks in either 4 hi or 2 hi, scared to try 4 low with the problem lol). i know it's in 4wd (hops when turning tight, good traction) is this an actual issue or just due to the cold?

oh its an 08' btw.

Thanks guys!
__________________
2008 GMC Canyon CC SLE Offroad, 4x4, Tow Package, Sunroof, XM, Onstar
- Elemental Designs 13Ov.2 powered by a NINe.2x
- Elemental Designs UP6's powered by a NINe.2
- Kenwood DNX7100
- Bluetooth kit, Boyo VTL300 reverse camera, ipod video cable
- eDead v1SE^2
Shorty2301 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 01-30-2008, 04:55 AM   #2 (permalink)
Senior Member
 
Join Date: Nov 2007
Location: Armada, MI
Posts: 412
Send a message via Yahoo to mike xlb
Default

mine did that on occasion, the transfer case works with the ECU to determine the right driving conditions, what gear the truck is in, if you have traction and all that jazz. My guess is to prevent damage it's forcing the truck to stay in the mode it was last left in due to the extreme cold your in right now.
__________________
2008 GMC Canyon 4x4 SLE-1 Z85
2005 Chevy Cobalt SS/SC
mike xlb is offline   Reply With Quote Quick reply to this message
Old 01-30-2008, 09:56 AM   #3 (permalink)
Senior Member
 
Join Date: Sep 2004
Location: Germantown, Maryland
Posts: 9,570
Send a message via AIM to rangerbob
Default

Just creep the truck forward a few inches and try again. It does that because the gears are not aligned.

I have to stirring my manual sometimes to get the transfer case to shift.
__________________
05 Canyon EC SLE - I5M Z71 GT4
V1 | FRAM Boost+RamAir | LED + HAW Strobes | BFG 33-12.5-15
Rancho | Bubaloo Skidz | MBRP Dumped System
Cat Gut| 3 x Lightforce Blitz | eFan | PCMforless <- very unhappy
1.5" TB/AAL/1" BL | Fold-A-Cover | Line-X OTR | Brake Box
rangerbob is offline   Reply With Quote Quick reply to this message
Old 01-30-2008, 01:50 PM   #4 (permalink)
Senior Member
 
Join Date: Sep 2007
Location: Saskatoon, SK. Canada
Posts: 543
Send a message via MSN to Shorty2301
Default

i tried going slow, creeping, going regular speeds, and stopped in neutral. it keeps blinking. we'll see how it is today its warmer now, only -30*C :p
__________________
2008 GMC Canyon CC SLE Offroad, 4x4, Tow Package, Sunroof, XM, Onstar
- Elemental Designs 13Ov.2 powered by a NINe.2x
- Elemental Designs UP6's powered by a NINe.2
- Kenwood DNX7100
- Bluetooth kit, Boyo VTL300 reverse camera, ipod video cable
- eDead v1SE^2
Shorty2301 is offline   Reply With Quote Quick reply to this message
Old 01-30-2008, 04:52 PM   #5 (permalink)
Senior Member
 
Canyon08Z71's Avatar
 
Join Date: Dec 2005
Location: Massachusetts
Posts: 4,767
Default

Try switching the transfer case to N and then to 2HI.
__________________
- Gerry
Advanced Vehicle Technologies
AVT Local & Remote Vehicle Tuning
AVT @ Facebook
Canyon08Z71 is offline   Reply With Quote Quick reply to this message
Old 01-30-2008, 10:54 PM   #6 (permalink)
Member
 
Join Date: Nov 2007
Posts: 48
Default

i had this problem too. if the already mentioned ideas don't work, it may be a bent connector down by the 4x4 system. before i bought my 07, it did this on the test drive, and before i agreed to any deal, the dealership took it into service and fixed it up.
kevinz is offline   Reply With Quote Quick reply to this message
Old 01-31-2008, 12:59 AM   #7 (permalink)
Senior Member
 
Join Date: Sep 2007
Location: Saskatoon, SK. Canada
Posts: 543
Send a message via MSN to Shorty2301
Default

was the same again today. maybe ill have a look under neath and look for a potential bent connector. but it started happening after me and my buddy when to the gym. before, it went in and out fine. we came out after it had warmed up (it was -43*C or so) and i went to switch from 2wd to 4 hi and it took longer than normal, about 10 seconds or so. but later when i went to put it in 2wd. it wouldnt move from 4hi to 2. is locked in 4, i know that, but the lights blink no matter what you press. tomorrow i will try putting it in neutral and then 2wd and see what happens.

Thanks guys! if this keeps up, a call to the dealer will be in order.
__________________
2008 GMC Canyon CC SLE Offroad, 4x4, Tow Package, Sunroof, XM, Onstar
- Elemental Designs 13Ov.2 powered by a NINe.2x
- Elemental Designs UP6's powered by a NINe.2
- Kenwood DNX7100
- Bluetooth kit, Boyo VTL300 reverse camera, ipod video cable
- eDead v1SE^2
Shorty2301 is offline   Reply With Quote Quick reply to this message
Old 01-31-2008, 03:15 AM   #8 (permalink)
Senior Member
 
Join Date: Nov 2007
Location: Armada, MI
Posts: 412
Send a message via Yahoo to mike xlb
Default

Quote:
Originally Posted by Shorty2301
Thanks guys! if this keeps up, a call to the dealer will be in order.
I would have been there already. 4x4 mode for an extended time can hurt your powertrain if the conditions are normal driving.
__________________
2008 GMC Canyon 4x4 SLE-1 Z85
2005 Chevy Cobalt SS/SC
mike xlb is offline   Reply With Quote Quick reply to this message
Old 02-01-2008, 02:15 PM   #9 (permalink)
Senior Member
 
Join Date: Sep 2007
Location: Saskatoon, SK. Canada
Posts: 543
Send a message via MSN to Shorty2301
Default

hmm, crawled under and seen that there is a small shaft seal leak on the front diff. i didn't check fluid level, could low fluid be the problem?
__________________
2008 GMC Canyon CC SLE Offroad, 4x4, Tow Package, Sunroof, XM, Onstar
- Elemental Designs 13Ov.2 powered by a NINe.2x
- Elemental Designs UP6's powered by a NINe.2
- Kenwood DNX7100
- Bluetooth kit, Boyo VTL300 reverse camera, ipod video cable
- eDead v1SE^2
Shorty2301 is offline   Reply With Quote Quick reply to this message
Old 02-01-2008, 08:22 PM   #10 (permalink)
Senior Member
 
Join Date: Jan 2008
Posts: 154
Default

dude... get out of Saskatchewan.

Saskatchewan is the problem!!
__________________
'04 GMC Canyon Xtra Cab Z71 SL 3.5L I5 4.10
2.0" TB/Shackle lift, 1/2" dif drop, Rancho 5000 shocks
Leer 100XL with bed/storage conversion, Thule racks
justplanecrazy is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Chevy Colorado & GMC Canyon forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -4. The time now is 11:52 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.0