Check Engine light P0455 - Chevy Colorado & GMC Canyon

ColoradoFans.com is the premier Colorado Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools
Old 10-25-2008, 09:00 PM   #1 (permalink)
Senior Member
 
Join Date: Feb 2008
Location: Batavia, New York
Posts: 620
Default Check Engine light P0455

Alright, I have looked at the search for this and it does say it can be caused by the fuel cap. However I also checked this issue and replaced the cap because of the same issue, that and it was broken. The fuel cap light only comes on when I have around 3/4 of a tank or less. I am not sure if it is the line itself. Because it would seem funny to have another bad fuel cap after only a month of use.

Any suggestions? Or anyone have to replace the line? Sounds like a pain in the ass. Truck is stock no lift or anything.
__________________
2004 Chevrolet Colorado Crew Cab, Green, Z71 4x4 with 3.73 (GT4) G80. Firestone Destination 31x10.5 15
Mods:
Spectre Air Filter, Optima Yellow Top 34-78, Imperial Tranny Cooler, Pioneer 7700MP HU, Pioneer Component Speakers with Sony Amp.
OffroadJunkie84 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 10-25-2008, 09:14 PM   #2 (permalink)
Senior Member
 
Join Date: Oct 2008
Location: North Atlanta, GA
Posts: 1,048
Default Re: Check Engine light P0455

Would also think it was the gas cap. Maybe you bought a bad (new) gas cap that does not seal good. Might try another. Do you smell and gas around the truck? Under the truck?

http://www.obd-codes.com/p0455
__________________
Steve
2007 GMC Canyon Z71-4x4 Crew Cab | 3.7 I5 - Auto | 4" Skyjacker suspension lift | 3" Performance Accessories body lift | 33x11.5x17 tires (going 35x12.5x17) | 3.73 gears | Custom blurred grille | 57 K&N | BPi VS | AMS EaAU 6081 | SSK MAF Adapter | NGK AFX w/ NTK WBO2 | HP Tuner Pro wideband tuned by ME! | AMSoil fluids FTW!
............2010 SESM Oct 22-24 Details Here
jackedupcanyon is offline   Reply With Quote Quick reply to this message
Old 10-25-2008, 11:28 PM   #3 (permalink)
Senior Member
 
Join Date: Oct 2006
Location: Fort Carson, CO
Posts: 6,410
Default Re: Check Engine light P0455

Odds are that the problem is elsewhere in the evap system.
__________________
2005 Z71 LS Crew Cab 4X4 L52, 4L60E, GT4, Silver Birch Metallic MAXX Shackles: http://www.355nation.net/forum/suspe...here-here.html MAXX Cam JR Lift Kit for 4X4 & 2WD Z71: http://www.355nation.net/forum/suspe...ering-kit.html
MAXX Stak Lift Kit for 2WD: http://www.355nation.net/forum/suspe...t-numbers.html PerforMAXX Body Lift: http://www.355nation.net/forum/suspe...y-spacers.html
ssgjurista is offline   Reply With Quote Quick reply to this message
Old 10-27-2008, 09:13 AM   #4 (permalink)
Senior Member
 
Join Date: Feb 2008
Location: Batavia, New York
Posts: 620
Default Re: Check Engine light P0455

Well I did notice the green seal for the gascap isn't as... how to put this.... springy? I dunno but it seems flat like my other one had been. Except for the fact it locks where as my other one just spun around. I wonder if I could stretch the seal back to what it was originally. I thought that was the major problem with the old caps?

It's not like I keep screwing in the cap alot after it clicks, I just make sure it clicks then try to pull on it lightly to make sure that it is locked properly.
__________________
2004 Chevrolet Colorado Crew Cab, Green, Z71 4x4 with 3.73 (GT4) G80. Firestone Destination 31x10.5 15
Mods:
Spectre Air Filter, Optima Yellow Top 34-78, Imperial Tranny Cooler, Pioneer 7700MP HU, Pioneer Component Speakers with Sony Amp.
OffroadJunkie84 is offline   Reply With Quote Quick reply to this message
Old 10-27-2008, 10:51 AM   #5 (permalink)
Senior Member
 
Join Date: Sep 2004
Location: Germantown, Maryland
Posts: 9,570
Send a message via AIM to rangerbob
Default Re: Check Engine light P0455

I've had a gas cap fail on me. Try replacing this first.
__________________
05 Canyon EC SLE - I5M Z71 GT4
V1 | FRAM Boost+RamAir | LED + HAW Strobes | BFG 33-12.5-15
Rancho | Bubaloo Skidz | MBRP Dumped System
Cat Gut| 3 x Lightforce Blitz | eFan | PCMforless <- very unhappy
1.5" TB/AAL/1" BL | Fold-A-Cover | Line-X OTR | Brake Box
rangerbob is offline   Reply With Quote Quick reply to this message
Old 10-27-2008, 10:06 PM   #6 (permalink)
Senior Member
 
Join Date: Oct 2008
Location: North Atlanta, GA
Posts: 1,048
Default Re: Check Engine light P0455

ditto. gas cap first.
__________________
Steve
2007 GMC Canyon Z71-4x4 Crew Cab | 3.7 I5 - Auto | 4" Skyjacker suspension lift | 3" Performance Accessories body lift | 33x11.5x17 tires (going 35x12.5x17) | 3.73 gears | Custom blurred grille | 57 K&N | BPi VS | AMS EaAU 6081 | SSK MAF Adapter | NGK AFX w/ NTK WBO2 | HP Tuner Pro wideband tuned by ME! | AMSoil fluids FTW!
............2010 SESM Oct 22-24 Details Here
jackedupcanyon is offline   Reply With Quote Quick reply to this message
Old 10-28-2008, 06:22 PM   #7 (permalink)
Senior Member
 
Join Date: Feb 2008
Location: Batavia, New York
Posts: 620
Default Re: Check Engine light P0455

I cleaned the seal on the gascap and then the filler hole. I just find it BS that I would have to replace a gascap that is only a month and a half old.
__________________
2004 Chevrolet Colorado Crew Cab, Green, Z71 4x4 with 3.73 (GT4) G80. Firestone Destination 31x10.5 15
Mods:
Spectre Air Filter, Optima Yellow Top 34-78, Imperial Tranny Cooler, Pioneer 7700MP HU, Pioneer Component Speakers with Sony Amp.
OffroadJunkie84 is offline   Reply With Quote Quick reply to this message
Old 10-29-2008, 12:08 AM   #8 (permalink)
Senior Member
 
Join Date: Oct 2006
Location: Fort Carson, CO
Posts: 6,410
Default Re: Check Engine light P0455

Quote:
Originally Posted by OffroadJunkie84
I cleaned the seal on the gascap and then the filler hole. I just find it BS that I would have to replace a gascap that is only a month and a half old.
When you replaced the gas cap before, did you buy it or did the dealer replace it under the special coverage?
__________________
2005 Z71 LS Crew Cab 4X4 L52, 4L60E, GT4, Silver Birch Metallic MAXX Shackles: http://www.355nation.net/forum/suspe...here-here.html MAXX Cam JR Lift Kit for 4X4 & 2WD Z71: http://www.355nation.net/forum/suspe...ering-kit.html
MAXX Stak Lift Kit for 2WD: http://www.355nation.net/forum/suspe...t-numbers.html PerforMAXX Body Lift: http://www.355nation.net/forum/suspe...y-spacers.html
ssgjurista is offline   Reply With Quote Quick reply to this message
Old 10-30-2008, 02:39 PM   #9 (permalink)
Senior Member
 
Join Date: Feb 2008
Location: Batavia, New York
Posts: 620
Default Re: Check Engine light P0455

I ended up buying it myself, I realized I was wordy in my email I sent them, because I originally said I had the 0455 code and the gas cap light come on and I did mention the cap was broken. I really didn't feel like fighting it but they were being dumb, the guy was giving me the run around about having to hook it up to their computer. I should have said "hey broken cap, you have to give me a new one" but I wasn't in the mood to argue, probably would have punched the guy... anyways....

I think cleaning the cap seal and the filler neck did the trick, no light came on. Wierd... it's not like it was really dirty just a little water and dirt. But I guess if it doesn't have a perfect seal it would do that, I don't see how it would be a large leak.

I'll keep you guys posted if it comes up again.
__________________
2004 Chevrolet Colorado Crew Cab, Green, Z71 4x4 with 3.73 (GT4) G80. Firestone Destination 31x10.5 15
Mods:
Spectre Air Filter, Optima Yellow Top 34-78, Imperial Tranny Cooler, Pioneer 7700MP HU, Pioneer Component Speakers with Sony Amp.
OffroadJunkie84 is offline   Reply With Quote Quick reply to this message
Old 12-01-2008, 11:39 AM   #10 (permalink)
Senior Member
 
Join Date: Feb 2008
Location: Batavia, New York
Posts: 620
Default Re: Check Engine light P0455

I know I'm double posting but... Same problem check engine light following a gas cap indicator. Now... it had been a heavy snow last week and one day I start my truck low and behold the light is gone, was like that for a day or so then it came back. Not sure what this could be a possible leaky hose or bad connection?
__________________
2004 Chevrolet Colorado Crew Cab, Green, Z71 4x4 with 3.73 (GT4) G80. Firestone Destination 31x10.5 15
Mods:
Spectre Air Filter, Optima Yellow Top 34-78, Imperial Tranny Cooler, Pioneer 7700MP HU, Pioneer Component Speakers with Sony Amp.
OffroadJunkie84 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Chevy Colorado & GMC Canyon forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -4. The time now is 04:27 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.0