4wd will not engage flashing light - Chevy Colorado & GMC Canyon

ColoradoFans.com is the premier Colorado Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools
Old 12-02-2008, 04:34 PM   #1 (permalink)
Member
 
Join Date: Jul 2006
Posts: 36
Default 4wd will not engage flashing light

I woke up this mornign to the first snow of the year and pulled out of my driveway to find the roads a bit slick so I decided to put the 05 Canyon into 4 hi. So I press the button and all it does is flash? So I press 2 hi and it flashes a few times then goes solid and I drive to work in 2 hi.

When I get to work I decided to put it into neutral and see if it will go into 4 hi then, but no luck still just flashes. So I try 4 low, I put it in neutral and I hear it go into low, but the 4 low light also just flashes so I try to drive and it is defenitely still in 2wd. So I push 2 hi and it goes back into that.

I tried putting it into 4hi at a stop, at low speed (a few mph), at higher speed (20 mph), and even while slowly rolling backwards all with no luck.

I also noticed that when I put the transmission into neutral the N light does not light up on the 4wd button panel. I thought it used to light up with a red light if I remember correctly???

Any ideas or other things to try?
bainer1290 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 12-02-2008, 05:04 PM   #2 (permalink)
Senior Member
 
Join Date: Jan 2008
Location: Johnstown, Pa
Posts: 737
Send a message via AIM to platinumZ71
Default Re: 4wd will not engage flashing light

mine did this acouple months ago when i 1st tried my 4x4 and u had to go thru this process i found on here...do a quick search u should be able to find it but u have the right idea i had to shift to neutral acouple of times while pulling the ebrake i think and then it worked and never had a problem since
__________________
08 Inferno Orange Z71 Colorado Crew Cab 4x4 I5
MODS: Spray-On Bed Liner, Lund Smoked Bug Shield, AVS Smoked Vent Visors
3rd brake light cover, 20%tint with windshield drop
Black Metal Taillight guards, Hunter Black Brush Guard
Black Verticle grille, Black housing halo headlights, Black front bumper
3" exhaust, Black H3 Wheels, mass airflow sensor...etc
platinumZ71 is offline   Reply With Quote Quick reply to this message
Old 12-02-2008, 05:24 PM   #3 (permalink)
Member
 
Join Date: Jul 2006
Posts: 36
Default Re: 4wd will not engage flashing light

I found a article that says the procedure is listed in the owner's manual. Is this true for my 05?
bainer1290 is offline   Reply With Quote Quick reply to this message
Old 12-02-2008, 07:51 PM   #4 (permalink)
Member
 
Join Date: Jul 2006
Posts: 36
Default Re: 4wd will not engage flashing light

Found the section in the manual on how to put it in neutral, did it 3 times, then tried 4 hi and low again but same flashing light...

What gives?
bainer1290 is offline   Reply With Quote Quick reply to this message
Old 12-02-2008, 07:59 PM   #5 (permalink)
Senior Member
 
Join Date: Feb 2007
Location: Hoffman Estates, IL
Posts: 3,881
Send a message via ICQ to coyote Send a message via AIM to coyote Send a message via Yahoo to coyote
Default Re: 4wd will not engage flashing light

If you search enough I am sure this has been discussed. It's been over a year since I have seen it though. When you say it was flashing in 4hi/lo and you knew it was in 2hi, do you mean that the light didn't go back to 2hi? But was flashing 4hi/lo when driving?
__________________
'06 Crew Silverado 4.8L 3.73 4WD G80 Granite Blue Metallic

'08 EC 3.7 Auto 3.73 4WD G80 Granite Black Metallic - Traded for 2006 Silvy

'05 EC, I5M, Z71, 4wd 4.10 gears, G80, SB Orange, 1.5" AAL, 1.5" TB lift, Lifted Club #115 - traded for 2008

'76 CJ5, 304 V8, 3spd, rebuild in progress.

AAL Install - CV Stress Relief

RIP Spike 9-25-2007
coyote is offline   Reply With Quote Quick reply to this message
Old 12-02-2008, 09:40 PM   #6 (permalink)
Senior Member
 
atxcoloradofan's Avatar
 
Join Date: Dec 2007
Location: Texas
Posts: 2,827
Send a message via AIM to atxcoloradofan Send a message via Yahoo to atxcoloradofan
Default Re: 4wd will not engage flashing light

it says in the manual a whole process you should go through to get it back to work and its not that 3 times deal. it says:

"On vehicles with an automatic transmission, if your transfer case does not shift into 4HI, your transmission indicator switch may require adjustment. With your transmission in NEUTRAL (N), press and release the 4HI button. While the 4HI indicator light is flashing, shift your transmission into PARK (P). Wait until the 4HI indicator light remains illuminated before shifting your transmission into gear. Press the 4HI button again to complete the shift. This will get you into 4HI, but you should take your vehicle in for service to restore normal operation."

and if that doesnt work, dont know what to tell ya. take it and let them see what the problem is.
__________________



Mud Club Member #19
Lifted Club Member #195
atxcoloradofan is offline   Reply With Quote Quick reply to this message
Old 12-02-2008, 10:30 PM   #7 (permalink)
Member
 
Join Date: Jul 2006
Posts: 36
Default Re: 4wd will not engage flashing light

Quote:
Originally Posted by coyote
If you search enough I am sure this has been discussed. It's been over a year since I have seen it though. When you say it was flashing in 4hi/lo and you knew it was in 2hi, do you mean that the light didn't go back to 2hi? But was flashing 4hi/lo when driving?
Correct, if I press 4hi it keeps flashing while parked or driving, it does not change back to 2hi.

I found a few discussions but nothing that has worked yet, everything that I have tried I have mentioned in this discussion.

I will try what you mentioned atxcolorado and let you know if it works. Thanks.

If I missed something please let me know.
bainer1290 is offline   Reply With Quote Quick reply to this message
Old 12-02-2008, 10:52 PM   #8 (permalink)
Senior Member
 
atxcoloradofan's Avatar
 
Join Date: Dec 2007
Location: Texas
Posts: 2,827
Send a message via AIM to atxcoloradofan Send a message via Yahoo to atxcoloradofan
Default Re: 4wd will not engage flashing light

now when you put into 4HI in the first place were you completely stopped?! or were you driving?! if you were driving that cant be good for it.
__________________



Mud Club Member #19
Lifted Club Member #195
atxcoloradofan is offline   Reply With Quote Quick reply to this message
Old 12-02-2008, 11:11 PM   #9 (permalink)
Senior Member
 
Join Date: Sep 2004
Location: Germantown, Maryland
Posts: 9,570
Send a message via AIM to rangerbob
Default Re: 4wd will not engage flashing light

It's shift on the fly 4WD? I put mine into 4HI at speed all the time with no problems.
__________________
05 Canyon EC SLE - I5M Z71 GT4
V1 | FRAM Boost+RamAir | LED + HAW Strobes | BFG 33-12.5-15
Rancho | Bubaloo Skidz | MBRP Dumped System
Cat Gut| 3 x Lightforce Blitz | eFan | PCMforless <- very unhappy
1.5" TB/AAL/1" BL | Fold-A-Cover | Line-X OTR | Brake Box
rangerbob is offline   Reply With Quote Quick reply to this message
Old 12-02-2008, 11:16 PM   #10 (permalink)
Senior Member
 
atxcoloradofan's Avatar
 
Join Date: Dec 2007
Location: Texas
Posts: 2,827
Send a message via AIM to atxcoloradofan Send a message via Yahoo to atxcoloradofan
Default Re: 4wd will not engage flashing light

oh ok, just said in the manual have to be at a certain slow speed or stopped to do it, so just goin off what it said on there.
__________________



Mud Club Member #19
Lifted Club Member #195
atxcoloradofan is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Chevy Colorado & GMC Canyon forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -4. The time now is 02:11 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.0