4 Wheel Drive Buttons not working - Chevy Colorado & GMC Canyon

ColoradoFans.com is the premier Colorado Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools
Old 02-13-2012, 01:00 PM   #1 (permalink)
Junior Member
 
Join Date: Feb 2012
Posts: 1
Default 4 Wheel Drive Buttons not working

Hi everyone!! I need some desperate help. I have a 2005 Chevy Colorado Z71.... I had the vehicle engaged in four wheel drive. When I came to a stop and tried to go again...the back end fish tailed out. And I looked down at my 4 wheel drive buttons on the dash and all of the lights were out. It must have just defaulted back to 2WD when the lights went out???

But now all of the buttons went out and it will not engage back into 4 wheel drive. I've tried the fuses.... pulled out the 4WD switch on the dash, messed around with that. Can't figure it out.... there were a few instances that the lights would go back on and when they did the vehicle would go into 4WD from where I left it and as soon as I pushed the 2WD drive button, all of the indicator lights would go out again and the vehicle would go into 2WD, but wouldn't go back into 4 when I tried to push that button. HELP!! Is it that whole button panel that needs to be replaces or do you guys think it's something deeper??? Any help is very much appreciated!!!
blacklab6986 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 02-13-2012, 08:39 PM   #2 (permalink)
Junior Member
 
Join Date: Jan 2012
Posts: 2
Default

I found out the problem I had was the 2/4 switch on the belly of the transverse case was corroded. I have a post on page 3 in this forum. Your problem could be a module failure or one of three different switches on the transverse case. Only the 2/4 switch is accessible without dropping the transverse case. Without successful testing you could be buying hundreds of dollars in parts before finding the source. Parts wholesale for the transverse case are hard to find because it is made by Izuzu. You can find the module wholesale from some online GM dealers IF that is the problem.
Anyways read my post on my fix and go from there.
Armitage360Garage is offline   Reply With Quote Quick reply to this message
Old 02-20-2013, 03:33 PM   #3 (permalink)
Junior Member
 
Join Date: Oct 2005
Location: North Fork, Ca
Posts: 7
Default 4wd not engaging

Got up to snow this morning. Usually I can drive right up the driveway (gravel) in 4wd. Engaged 4wd, light came on but I could tell that the front drive wasn't engaged even though the light came on. Didn't hear the normal "clunk" when pressing the 4wd high button. Same with the 4wd Low, says it's engaged but it's not.
mediaguy is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Chevy Colorado & GMC Canyon forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -4. The time now is 02:55 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.0