Key fob - Chevy Colorado & GMC Canyon
 
LinkBack Thread Tools Display Modes
post #1 of 17 (permalink) Old 07-12-2013, 07:59 PM Thread Starter
Junior Member
 
Join Date: Jul 2013
Posts: 4
Key fob

2005 Colorado with remote entry key fob. I have it set up to flash parking lights when I unlock with the key fob. All of a sudden it beeps the horn THREE TIMES when unlocking with the fob. It is NOT the same as when it is setup to beep. Very annoying. The dealer service folks couldn't help me. It only happens if the truck has been sitting for awhile. Help!
green is offline  
Sponsored Links
Advertisement
 
post #2 of 17 (permalink) Old 07-13-2013, 12:15 AM
Junior Member
 
Join Date: Sep 2012
Location: Wisconsin
Posts: 19
Mine does this when I use my spare keys, which the key fob doesn't work. So I unlock it with the key. Then does that for a few days after then stops. I'm not sure what causes it but it goes away.
AustinWisc is offline  
post #3 of 17 (permalink) Old 07-15-2013, 01:02 AM
Member
 
Spad's Avatar
 
Join Date: Sep 2012
Location: Central Indiana
Posts: 74
Mine suddenly started doing that about a month or so ago. Never did figure out why . . . it started after my wife drove it, and she said she set the alarm off by using the key to unlock the truck and not the fob. I tried different settings but nothing seemed to affect it. I told my wife maybe she had mistreated the truck and it was telling on her, lol

It finally stopped doing it after a couple weeks (nothing I did . . . it just stopped). Only thing I can attribute it too was it started after a very wet couple of weeks, and stopped after a very dry week. Coincidence? I dunno.

Red 2005 Colorado Quad cab Z71 4X4

Last edited by Spad; 07-15-2013 at 01:05 AM.
Spad is offline  
 
post #4 of 17 (permalink) Old 07-15-2013, 11:07 AM
Senior Member
 
Join Date: Apr 2008
Posts: 2,500
If someone unlocked the doors without the fob, or tripped the alarm it will do bizarre things like this until you do the "correct " combo of locking and unlocking, usually by accident, I cant remember the actual sequence but I have gone through this, try repeatedly locking and unlocking the door with it closed and open, eventually you will sort it out, I remember reading somewhere that this is the trucks way of letting you know that the truck was entered either with a key when the alarm was set or unlocked manually in some way...

Bear with me while I speak, and after I have spoken, mock on. [Job 21:3]

2006 3.5L, Crew Cab, Z71, Dark Metallic Red
Gift from wife Christmas 2007 (21000 miles)
100,000 miles on 01/28/13
110,000 miles on 10/22/13
120.000 miles on 07/08/14
130,000 miles on 03/19/15
140,000 miles on 11/19/15
davn is offline  
post #5 of 17 (permalink) Old 07-17-2013, 04:01 PM Thread Starter
Junior Member
 
Join Date: Jul 2013
Posts: 4
I have tried every combination I can think of, and still does it. Even beeps five times if I hit "lock" button first. I tried disconnecting the battery, but that didn't do it. Hopefully, it will go back to normal after a while, when it gets tire of annoying me.
green is offline  
post #6 of 17 (permalink) Old 07-29-2013, 01:47 PM Thread Starter
Junior Member
 
Join Date: Jul 2013
Posts: 4
Update. After 2-3 weeks, the problem went away, as a couple of you offered. Does not seem like a very user-friendly system. Anyway, I and my neighbors are happy.
green is offline  
post #7 of 17 (permalink) Old 07-29-2013, 02:19 PM
Senior Member
 
Join Date: Apr 2008
Posts: 2,500
just make sure you do not unlock it with the key after having locked it with the fob, It doesn't seem to like that, at least in my case(s) ....

Bear with me while I speak, and after I have spoken, mock on. [Job 21:3]

2006 3.5L, Crew Cab, Z71, Dark Metallic Red
Gift from wife Christmas 2007 (21000 miles)
100,000 miles on 01/28/13
110,000 miles on 10/22/13
120.000 miles on 07/08/14
130,000 miles on 03/19/15
140,000 miles on 11/19/15
davn is offline  
post #8 of 17 (permalink) Old 07-29-2013, 02:20 PM
Senior Member
 
britishrich's Avatar
 
Join Date: Mar 2012
Posts: 843
I always found even one beep upon locking to be invasively loud and unnecessary.

2005 I4, Z85
7" Touch Screen Double DIN
Paint matched Bumper
Decals removed
Door "bumpers" removed
MB TKO Wheels
Goodyear 255/45/20s
Custom Painted Hood stripe

"Failure only occurs when you stop trying"
britishrich is offline  
post #9 of 17 (permalink) Old 07-29-2013, 02:40 PM
Senior Member
 
Join Date: Apr 2008
Posts: 2,500
Quote:
Originally Posted by britishrich View Post
I always found even one beep upon locking to be invasively loud and unnecessary.
you can change that I believe...... let me look into it...

here you go

Remote Keyless Entry (RKE) Feedback
This feature allows you to program the Remote
Keyless Entry (RKE) feedback to a preferred setting.
To set your choice for this feature:
1. With the engine off, turn the key to LOCK/OFF.
Do not remove the key from the ignition.
2. Press and hold the lock and unlock buttons on
the RKE transmitter at the same time. Hold both
buttons until the DIC display shows the current RKE
feedback mode.
3. To view the next available mode, press and hold
the reset stem until the mode appears. Release
the reset stem and press and hold again to view
the next mode.
4. Once the desired mode is shown on the DIC
display, briefly press the reset stem to set your
choice. The DIC display then clears.
The following are the available modes:
RFA 1 (default):
This mode flashes the parking lamps
when you press the lock or unlock buttons on the
RKE transmitter.

RFA 2:
This mode flashes the parking lamps and
sounds the horn when you press the lock button on the
RKE transmitter. This mode also flashes the parking
lamps when you press the unlock button on the
RKE transmitter.

RFA 3:
This mode flashes the parking lamps and
sounds the horn when you press the lock or unlock
buttons on the RKE transmitter.

RFA 4:
This mode disables RKE feedback. There will
be no feedback when you press the lock or unlock
buttons on the RKE transmitter.

3-

Bear with me while I speak, and after I have spoken, mock on. [Job 21:3]

2006 3.5L, Crew Cab, Z71, Dark Metallic Red
Gift from wife Christmas 2007 (21000 miles)
100,000 miles on 01/28/13
110,000 miles on 10/22/13
120.000 miles on 07/08/14
130,000 miles on 03/19/15
140,000 miles on 11/19/15

Last edited by davn; 07-29-2013 at 02:56 PM.
davn is offline  
post #10 of 17 (permalink) Old 08-04-2013, 10:15 PM Thread Starter
Junior Member
 
Join Date: Jul 2013
Posts: 4
Quote:
Originally Posted by britishrich View Post
I always found even one beep upon locking to be invasively loud and unnecessary.
Agreed
green is offline  
post #11 of 17 (permalink) Old 08-05-2013, 08:29 AM
Senior Member
 
britishrich's Avatar
 
Join Date: Mar 2012
Posts: 843
[QUOTE=davn;1974634]you can change that I believe...... let me look into it...

here you go

Thanks Davn but mine doesn't have factory keyless and I never set up my aftermarket to do the horn :)

I'm sure someone will find that useful though.

I was talking more about how I don't need to know my neighbor 4 houses a way just locked their car LOL

2005 I4, Z85
7" Touch Screen Double DIN
Paint matched Bumper
Decals removed
Door "bumpers" removed
MB TKO Wheels
Goodyear 255/45/20s
Custom Painted Hood stripe

"Failure only occurs when you stop trying"
britishrich is offline  
post #12 of 17 (permalink) Old 03-11-2017, 05:40 PM
Junior Member
 
Join Date: Mar 2017
Location: 2 N Fernwood Clearwater Fl 33765
Posts: 16
Garage
Both of my key fobs stopped working so I tried to reprogram them but still not working. Took my 2005 Colorado to the dealer and every thing checked out ok !! They said I could change out parts one at a time to see if that worked !! The new module for it was $400.00 I can use my keys !!!!!! Has anyone else have this problem !
The Tin Man
toshayar is offline  
post #13 of 17 (permalink) Old 03-12-2017, 12:45 PM
Senior Member
 
Join Date: Dec 2010
Location: Homestead, Florida
Posts: 4,788
Quote:
Originally Posted by toshayar View Post
Both of my key fobs stopped working so I tried to reprogram them but still not working. Took my 2005 Colorado to the dealer and every thing checked out ok !! They said I could change out parts one at a time to see if that worked !! The new module for it was $400.00 I can use my keys !!!!!! Has anyone else have this problem !
The Tin Man
Is the truck completely stock? If not in factory configuration, what has been added or changed?
cart7881 is online now  
post #14 of 17 (permalink) Old 03-12-2017, 05:53 PM
Junior Member
 
Join Date: Mar 2017
Location: 2 N Fernwood Clearwater Fl 33765
Posts: 16
Garage
I bought it used with 12000 on it . I believe it's stock as the truck is an ls my glove box says its a z85
toshayar is offline  
post #15 of 17 (permalink) Old 03-12-2017, 07:52 PM
Senior Member
 
Join Date: Dec 2010
Location: Homestead, Florida
Posts: 4,788
So the radio is stock and there aren't any added electronics such as amplifiers or security systems or remote start, etc? Do you keep anything plugged into the accessory ports? Did both remotes stop working at the same time? Not mentioned, but I'm assuming the batteries have been replaced. Any work done on the truck lately? If the Dealer said that everything checked out okay they must have had the remotes operating properly at that time. How else would "everything check out okay"? If the remotes worked for the Dealer then something may be interfering with the signal. What happens if you press the red button on the remote?

Pull the right kick panel and check to make sure that the antenna is securely connected to the BCM.
cart7881 is online now  
post #16 of 17 (permalink) Old 03-13-2017, 08:13 PM
Junior Member
 
Join Date: Mar 2017
Location: 2 N Fernwood Clearwater Fl 33765
Posts: 16
Garage
Nothing new added it has all the bells a Thanks for replying !nd whistles on it except power seats. They tested my fobs with a goofy tester that indicated they were working and took the truck in the shop to put a diaganostic test on it. They just stopped working. Both at one time But my accessory outlets do blow a fuse when I plug in my car vac . I can live without them but I'm a guy that wants every thing working !!!
toshayar is offline  
post #17 of 17 (permalink) Old 03-13-2017, 08:15 PM
Junior Member
 
Join Date: Mar 2017
Location: 2 N Fernwood Clearwater Fl 33765
Posts: 16
Garage
Crazy computer rearranged my typing !!!!!!!!!!!
toshayar is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevy Colorado & GMC Canyon forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome