Engine Code (P0506) - Chevy Colorado & GMC Canyon

ColoradoFans.com is the premier Colorado Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools
Old 02-15-2007, 03:42 PM   #1 (permalink)
Junior Member
 
Join Date: May 2006
Posts: 23
Send a message via Yahoo to GTO2Canyon
Default Engine Code (P0506)

Thru this code last night, had it checked today. Code description was "The PCM determined that the engine RPM is lower than expected for the current engine operating conditions.". I have discounted the neg. battery terminal to attempt at reset. Has anybody ever seen this code before.

Truck has 51,000m ans NO mods.
__________________
'05 Crew SBM I-5 Z85 2WD - SOLD

'05 2500HD EC/SB 2WD
GTO2Canyon is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 02-15-2007, 03:47 PM   #2 (permalink)
Senior Member
 
Join Date: Jun 2004
Location: Latrobe, PA
Posts: 1,824
Default

I have it too. I think cleaning the throttle body out fixes it.
__________________
brewer15650 is offline   Reply With Quote Quick reply to this message
Old 02-15-2007, 03:53 PM   #3 (permalink)
Junior Member
 
Join Date: May 2006
Posts: 23
Send a message via Yahoo to GTO2Canyon
Default

Thanks for the info. Looks my son get his first lesson in cleaninf a TB.
__________________
'05 Crew SBM I-5 Z85 2WD - SOLD

'05 2500HD EC/SB 2WD
GTO2Canyon is offline   Reply With Quote Quick reply to this message
Old 02-15-2007, 03:56 PM   #4 (permalink)
Senior Member
 
Join Date: Oct 2004
Location: Connecticut USA
Posts: 5,591
Send a message via AIM to Rsquires67
Default

Yea try that first. I had to do mine around 40k
__________________
VOTE for me please in TOTY!!!! viewtopic.php?f=24&t=67915
Rsquires67 is offline   Reply With Quote Quick reply to this message
Old 02-15-2007, 03:59 PM   #5 (permalink)
Junior Member
 
Join Date: May 2006
Posts: 23
Send a message via Yahoo to GTO2Canyon
Default

Sorry for the repost. I used the search button and i'll be damned. Found the info. Gotta work on the search than the question. :D
__________________
'05 Crew SBM I-5 Z85 2WD - SOLD

'05 2500HD EC/SB 2WD
GTO2Canyon is offline   Reply With Quote Quick reply to this message
Old 02-17-2007, 06:34 PM   #6 (permalink)
Junior Member
 
Join Date: May 2006
Posts: 23
Send a message via Yahoo to GTO2Canyon
Default

Pulled the Tb today. Cleaned it up and reinstalled, it already idles better. I'll road test it tonight
__________________
'05 Crew SBM I-5 Z85 2WD - SOLD

'05 2500HD EC/SB 2WD
GTO2Canyon is offline   Reply With Quote Quick reply to this message
Old 02-17-2007, 10:28 PM   #7 (permalink)
Senior Member
 
Join Date: Jul 2005
Location: When I'm king, things are gonna be different around here.
Posts: 1,806
Default

What did it look like before you cleaned it?
__________________
2005 Z85 2wd Crew-Cab, Black, I-5, Auto, 17-inch ZQ8 wheels.

I know Victoria's secret.

Always remember: Pillage before you burn.
Rick_crew is offline   Reply With Quote Quick reply to this message
Old 03-27-2007, 01:51 AM   #8 (permalink)
Senior Member
 
Join Date: Jan 2004
Location: Newark, DE
Posts: 2,966
Send a message via AIM to J-man67
Default

I just did mine. Had the light for p506 over a month and it finally warmed up enough to do it. Intake side looked ok...other side had a good amt of carbon build-up. Grabbed my chem gloves, some cleaner and sprayed/wiped away. Oiled the ends of the butterfly valve, and re-installed. Also picked up some MAF cleaner. Cleaned the K&N too. Put it all back together and BAM, no Check engine light and idle is up from 550 to 650. Loving life again. Its funny that the dealership always said my rough idle was normal....stupid mother fuckers!
__________________
GET IT DIRTY!!!!!
2004 Colorado Ext cab LS z71 4x4 - traded :(
2007 Harley D. FXDB (Street Bob)
2006 Kawasaki KFX400
2004 Kawasaki zx636R
J-man67 is offline   Reply With Quote Quick reply to this message
Old 04-02-2007, 07:19 PM   #9 (permalink)
cj
Junior Member
 
Join Date: Aug 2005
Location: high desert
Posts: 26
Send a message via Yahoo to cj
Default

mine truck is running ruff as well. How do you do the throtle body cleaning?
cj is offline   Reply With Quote Quick reply to this message
Old 04-03-2007, 11:52 AM   #10 (permalink)
Senior Member
 
Join Date: Sep 2004
Location: Germantown, Maryland
Posts: 9,570
Send a message via AIM to rangerbob
Default

Got search? It's been discussed before.....
__________________
05 Canyon EC SLE - I5M Z71 GT4
V1 | FRAM Boost+RamAir | LED + HAW Strobes | BFG 33-12.5-15
Rancho | Bubaloo Skidz | MBRP Dumped System
Cat Gut| 3 x Lightforce Blitz | eFan | PCMforless <- very unhappy
1.5" TB/AAL/1" BL | Fold-A-Cover | Line-X OTR | Brake Box
rangerbob is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Chevy Colorado & GMC Canyon forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -4. The time now is 08:39 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.0