ABS fault and TRACTION fault - Chevy Colorado & GMC Canyon

ColoradoFans.com is the premier Colorado Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools
Old 08-26-2012, 03:57 PM   #1 (permalink)
Junior Member
 
nestorgarcia577's Avatar
 
Join Date: Aug 2012
Posts: 11
Default ABS fault and TRACTION fault

i keep getting this message on the screen on the dash board that when i turn my truck on it says abs fault and traction fault and the abs light stays on and the brake light stay on...but the brake is not on...its realeased but it says its on..if somebody knows what it is or an idea i GREATLY APPRECIATE IT
nestorgarcia577 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 08-26-2012, 04:12 PM   #2 (permalink)
Senior Member
 
08Canyon's Avatar
 
Join Date: Oct 2011
Posts: 5,881
Default

Have you done any work to the truck? Most times it's the abs ring in the front hub. It has to be perfectly seated. I'm sure the traction fault is due to abs.
08Canyon is offline   Reply With Quote Quick reply to this message
Old 08-26-2012, 04:23 PM   #3 (permalink)
Junior Member
 
nestorgarcia577's Avatar
 
Join Date: Aug 2012
Posts: 11
Default

no i havent done any work to it really...they keep telling me it could be the speed sensor but then again i really dont know if thats whats causing it to throw all them lights at me
nestorgarcia577 is offline   Reply With Quote Quick reply to this message
Old 08-26-2012, 05:03 PM   #4 (permalink)
Senior Member
 
Join Date: May 2012
Location: Michigan
Posts: 122
Default

Id go with the wheel speed sensor. Ive had many of them go bad over the years on different vehicles and thats exactly what happens with the lights. Finding which one is the culprit is the hard part.
lukpat23 is offline   Reply With Quote Quick reply to this message
Old 08-26-2012, 05:18 PM   #5 (permalink)
Senior Member
 
A VICTORY STICK's Avatar
 
Join Date: Aug 2012
Posts: 153
Default

It could be a bad abs sensors thr thing with that is they are a two piece unit one reading the wheel speed and the one in the hub if it is in the hub, the hub must be replaced because they are not servicable. good luck
__________________
AEM intake tube. Airrade throttle body spacer. Supermode throttle body. Supermod spring delete. denso plugs. AVT tune.Jet stage 2 chip and custom exhust. and many others
A VICTORY STICK is offline   Reply With Quote Quick reply to this message
Old 08-26-2012, 05:43 PM   #6 (permalink)
Junior Member
 
nestorgarcia577's Avatar
 
Join Date: Aug 2012
Posts: 11
Default

thanks for all your help...
nestorgarcia577 is offline   Reply With Quote Quick reply to this message
Old 08-26-2012, 09:56 PM   #7 (permalink)
Senior Member
 
Join Date: May 2012
Location: Michigan
Posts: 122
Default

Yeah, It should be a wheel speed sensor (same thing as an ABS sensor) check especially the front two to make sure you didnt get a wire pinched and broke some how, ive seen that too. Make sure that the pigtail is plugged into the hub good and that the ends are not corroded. If that all checks good then its time to replace the hubs.
lukpat23 is offline   Reply With Quote Quick reply to this message
Old 08-26-2012, 10:57 PM   #8 (permalink)
Junior Member
 
nestorgarcia577's Avatar
 
Join Date: Aug 2012
Posts: 11
Default

Thankz lukpat23....im gonna have to try the speed aensor first and then go from there and see what happens then...thankz
nestorgarcia577 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Chevy Colorado & GMC Canyon forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -4. The time now is 09:20 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.0